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Module 4: Change Detection and Area 
Estimation   

The goal of this Module is to continue building on the skills you’ve learned during this online training 

course to produce a change map. You will first create two date transforms of your Landsat derived data 

to investigate and map regions that have undergone the land cover transitions that you are interested in 

monitoring and mapping. Then you will build a model, again using the random forests algorithm and 

training data, to generate a change map. Finally you will use a second set of reference data to update 

the estimates of areas undergoing change and to assess the accuracy of the resulting map product.  

Modules 3 and 4 have been adapted from Exercises and material developed by Dr. Pontus Olofsson, 

Christopher E. Holden, and Eric L. Bullock at the Boston Education in Earth Observation Data Analysis in 

the Department of Earth & Environment, Boston University. To learn more about their materials and 

their work, visit their github site at https://github.com/beeoda. 
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Exercise 9: Change Detection 

Introduction 

The goal of this assignment is use what you have learned so far during this online training course to 

produce a change map. It requires two dates of imagery which are sufficiently far apart for change 

detection. You will call these two images Date 1 and Date 2.  

You can choose to study forest loss and/or regrowth or any other land change process.  

There are various methods of change detection, all with their pros and cons. This online training course 

will introduce you to just a few, which may or may not be suitable to your needs in the future.  

Historically, the most common method of change detection in remote sensing has been post-

classification comparison. Using this method you would classify two maps separately, and create a 

change map out of where they differ. While this is computationally efficient compared to other 

methods, it is not recommended and will not be utilized in this online training course. There are a few 

reasons why this is not recommended: 

1. Errors in the change map are multiplicative from the errors of the two classified single-date maps. 

Since the accuracy of the change map is directly dependent on the accuracies of the parent maps, 

overall change accuracy tends to be low. This often results in over-estimated total change area. 

2. This method tends to ignore subtle changes within a class. It is difficult to study classes such as 

degradation and regrowth when change is solely based on map classification.  

For these reasons, we recommend creating change maps based on changes in the raw data instead of 

changes in maps. In this exercise, you will learn how to directly classify change based on the information 

in both of your images. 

Objectives 

 Make sure you start with two cloud-masked images from different dates. 

 Create a multi-temporal transform to help locate areas of change in your images. You will be 
introduced to a few possible methods that highlight the differences in the images. 

 Create ROIs for your map that contain samples of stable classes and regions of all the change 
classes you have defined for your final change map. 

 Produce a change map. Like creating your classification images, this may take a few tries to 
perfect. 
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 Setting up the time 2 Image 

A. Project Set up 
1. Open QGIS by double-clicking on the QGIS shortcut on your desktop. 

2. Load the two cloud free composite rasters - not the classified maps you made yesterday.  

i. Click on the Add Raster Layer Button. 

ii. Navigate to the C:\Change_detection\Data\Composite folder and select the file called 
S_Thailand_2008_2010_305_90_Composite.tif.  

iii. Repeat to load the S_Thailand_2013_2015_305_90_Composite.tif. 

Note: If, instead of working with the cloud free composite generated in Google Earth Engine, you decide 
to work with raw Landsat Data, you will need to create a stack of the second image (Date 2) – after 
removing clouds and converting to reflectance values. Also make sure that the stack contains the same 
bands as the Date 1 stack. You’ll need to pay special attention to this if one of the images is a L8 image 
and the other a L5 or L7 image.  

B. Subset images 
1. Sub-set the two images. 

i. Go to Raster > Extraction > Clipper. 

ii. Set S_Thailand_2013_2015_305_90_Composite.tif as the input file. 

iii. Set the output file as 
C:\Change_detection\Data\Composite\imagery_subset\2013_Subset.tif. 

iv. Set the Clipping mode to Mask layer. 

v. Press Select to set the shapefile you will use as your Mask layer. Specify 
Processing_Subset.shp (found in C:\Change_detection\Data\Shapefiles\Thailand\). 

vi. Hit OK to execute. Click OK when the Processing has completed.  

vii. Close the Clipper dialog box. 

C. Remove bands from the 2013 composite stack  
You will need to remove the ancillary bands from the 2013 composite stack like you did in the 2008 

stack during Exercise 7. You will make two new stacked images. The first will have only the Landsat 

bands (bands 1-6 in the cloud free composite); the three NDVI bands and count will be dropped. Then 

you will repeat this but keep the Landsat bands and the three NDVI bands – you will just be dropping the 

count band.  

1. Open the Translate tool by clicking on Raster > Conversion > Translate (Convert Format)… 
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2. Select the 2013_Subset layer as the Input Layer. 

3. Save the Output layer in C:\Change_detection\Data\Composite\imagery_subset. Name it 
2013_Sub_6band.tif. 

4. Now select the Edit pencil at the bottom of the screen 

 

5. You will type in the bands you are interested in saving to your raster stack in the script in the 
lower panel of the screen. Type the text, found on the yellow line below, in between 
gdal_translate and –of in the script window. It is important to type it in (or copy and paste) 
exactly as it appears below, as the spaces are important. When you are done, your script box 
should appear as the image below. Make sure there is a space between the -b 6 and the –of. 

-b 1 -b 2 -b 3 -b 4 -b 5 -b 6  
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6. Click OK when the processing is completed. 

7. Repeat these steps to get a stacked raster with the 6 Landsat bands and the three ndvi bands.  

i. Name this file 2013_Sub_9band.tif. 

ii. The code you will enter is found below. 

-b 1 -b 2 -b 3 -b 4 -b 5 -b 6 -b 7 -b 8 -b 9 

D. Format the 2008 image 
1. Repeat steps B, image subsetting, and C, removing unnecessary bands, for the 2008 image. Note, 

if you still have these files saved from the exercises in Module 3, feel free to load those instead of 
repeating your work. They should be located in the folder called, 
C:\Change_detection\Data\Composite\imagery_subset. The final tif rasters were named 
2008_Sub_6band.tif and 2008_Sub_9band.tif.  

E. Save your QGIS project 
1. Remove the intermediate image files such that the only rasters loaded in your project are the 

2008 9 and 6 band image and the 2013 9 and 6 band image. 
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2. Save your project as Change_Det.qgs in the folder QGIS projects folder 

(C:\Change_detection\QGIS_Projects\). 

F. Display the subset images in matching stretches 
1. Pick a stretch that you like (one suggestion would be swir, nir, red (6, 4, 3) false color composite). 

Apply this stretch to one of the subset images. 

2. Right click on the image name under Layers and go to Styles > Copy Style. 

 

3. To apply this matching stretch to your other subset image, right click on the second image and go 
to Styles > Paste Style. 

 Single-date transformations 

A. Explore differences in your data 
1. Toggle back and forth between your images (uncheck the box next to the top subset image in the 

Layers panel). Zoom in and pan around if needed. Are there any distinct areas that seem to be 
changing?  

Large changes are likely to be visible by doing this, but small changes will not be. Even large changes can 

be difficult to detect by just comparing the original images. One method to help changes stand out more 

clearly is by creating a multi-temporal transform.  

To do this, you must first decide on what type of transformation you would like to do to your imagery. 

There are different types of transforms, each with their own advantages. By creating a transform you 

are leveraging multiple bands of information in an image to highlight specific information that you are 

looking for. The transformation that you do should correspond with what type of change you are looking 

for. 



Remote Sensing for Forest Cover Change Detection 7 

 

Use the tables below to guide you in deciding what transformation you would like to do. This is just a 

small list of some of the more common transformations, but it by no means includes them all. Once you 

have decided on a transformation, you will perform it on both images. The difference in the resulting 

images will be your multi-temporal transformation.  

 

Note about Tasseled Cap: the Tasseled Cap transformation was designed to transform spectral bands to 
new uncorrelated bands representing three distinct phases of vegetation: brightness, greenness, and 
yellowness (or wetness). The coefficients that have been calculated for the transformation are different 
depending on which sensor you are using, and whether you are using surface reflectance or TOA 
reflectance. Since you are working with a composite of Landsat 5, 7 and 8 this creates more complexities 
in the workflow so you will not use this transform during the course. 

B. NBR Single-date transformation for Date1 image 
1. Open up the Raster Calculator in QGIS, located in Raster > Raster Calculator.  This tool allows you 

to perform calculations on the pixel values of raster files. 

Note: Under Raster bands you will see a list containing each band of each raster file you have opened in 
your Layers. The listing that ends in ‘@1’ corresponds to band 1 of the corresponding file, ‘@2’ is band 2, 
and so on. 

2. Using the equation for the NBR transformation, write the expression under Raster calculator 
expression panel.  

i. Instead of typing in each band name, double-click the band name in the Raster bands panel to 
automatically add it to the Raster calculator expression panel. 

ii. Save the output layer in C:\Change_detection\Data\Composite\imagery_subset. Name it 
something that makes sense like 2008_nbr.tif. 
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iii. Your Raster calculator box should look something like this expression, which is calculating 
NBR: 

 

iv. To perform the calculation, click OK. 

3. The output file is a NBR transformation for your 2008 image. If you’d like, stretch the transform 
image appropriately and compare it to one of your Landsat images. 

i. To apply a single-band stretch right click on the file and go to Properties > Style. 

ii. Under Render type select Singleband pseudocolor. 

iii. Select a color scheme you are happy with. 

iv. Click Classify to apply the color stretch to the single-band image. 

v. Click OK and the color scheme and stretch should be applied to your transform. 

4. Switch back and forth between your transform and your Landsat image. How do the transformed 
values relate to what you know about those areas? Do the transformed image layer values vary 
between forest cover and built up lands?  

C. Single-date transform for Date2 image 
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1. Repeat these steps for your second image, 2013_Sub_9band.  

2. Copy the style from the 2008 transformed image and paste it to the 2013 image (hint: right click 
on the layers in the Layers Panel). 

3. Toggle back and forth between the 2008 transformed image and the 2013 one. Do you notice any 
differences? 

 

 

 Multi-temporal transform, or difference layers 

Now that you have two single-date transformations, you can use them to create a multi-temporal 

transform, or a difference layer. Since these indices are used to highlight information in the individual 

images, differencing them will help highlight areas of change between the images. 

1. Open up the Raster Calculator in QGIS, located in Raster > Raster Calculator.   

2. In the Raster calculator expression box, write an expression that subtracts the date1 (2008) NBR 
transformation from the date2 (2013) NBR transformation.  

i. Use an appropriate name like NBR_diff.tif in 
C:\Change_detection\Data\Composite\imagery_subset for the file in Output layer. 

ii. Your Raster calculator box should look something like this expression illustrated below, which 
is calculating a NBR difference: 
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iii. To perform the calculation, click OK. 

In the difference layer, or multi-temporal transform, the large positive and the large negative values are 
an indicator of change. While the values close to 0 likely represent no changes- at least no changes in 
land cover that the NBR transform is sensitive to.  

3. Apply a singleband pseudocolor render type and stretch to the multi-temporal transform, named 
NBR_Diff.tif. Select a color gradient that reflects both the high and low extreme values and has 
values close to 0 assigned a light color. 

i. Remember to select the Classify box to update the values in the dialogue box. 

ii. You can double click on the values in the Value field to the left of the color swatches to 
manually update interval values.  

iii. Make sure you repeat this for the labels so that they all match. 

iv. Select OK. 

v. Refer to following image for an example. 
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Note: A large difference value (either dark red or dark blue) is an indication of land cover changes 
occurring between the two images.  

Investigate the multi-temporal transform image, in addition to the Landsat images. Where are some 
clear examples of change? Which areas seem to have stable land cover between the two years?  

 

4. Add in the Change_Examples.shp shapefile. It is located in the 
C:\Change_detection\Data\Shapefiles\Data_Exploration folder.  
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i. Change the color to transparent with a dark border that is visible on the color ramp scheme 
you selected for the multi-temporal transform (difference layer). You can do this by selecting 
Outline: Simple line as the Symbol layer type.  

ii. Select OK. 

 
5. You might need to move this layer to display on top of the NBR difference layer, depending on the 

order that the layers loaded into the Layers Panel. 

6. Next examine the map window. What do the difference values look like in these example change 
areas? Why do some areas have positive difference values (blue in image above), while others 
have negative difference values (red)? 
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7. If you’d like to see what these areas look like using the aerial imagery library in Google Earth, you 
can navigate to the data folder and double click on the kmz file called Change_Examples.kmz in 
C:\Change_detection\Data\Shapefiles\Data_Exploration. This will open Google Earth with the 
same shapes you have loaded into QGIS – in a Temporary Places folder.  

i. If the time slider isn’t loaded by default you can click on the show historical imagery icon.  

 

ii. Once the slider appears, you can slide along the timeline to see the available archive of aerial 
photos and investigate what kinds of changes are occurring in these sample regions. 
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 Advanced Multi-Temporal Transforms 

A. Principal Component Analysis 
One slightly more advanced method of data exploration that can be utilized in change detection is 

Principal Component Analysis (PCA). PCA transforms the data along orthogonal axes of variability in 

spectral space. In other words, PCA transforms the spectral bands into new variables that are 

uncorrelated with one another. Since the spectral bands are highly correlated, this can be a way of 

reducing the amount of variables needed to produce the same amount of information. The Principal 

Components are ordered so that the first few will contain the most variation from the original variables, 

while the last few will contain the least. 

One way of using PCA for change detection is by performing it on a multi-date image stack. Since areas 

of change will have low correlation between all the variables (spectral bands) when compared to stable 

pixels, these changes will be accentuated in the Principal Components. The output of doing so will be a 

Principal Components image with N number of Components (with N representing the number of bands 

in the multi-date image stack). The first few will capture the majority of the variation within the bands. 

Since changed pixels will have the highest variation, these Components will be largest in areas of 

change. To perform a PCA, first stack your two Landsat images. 

Note: you can run this on either the 6 band stacked images or the 9 band stacked images. Remember, 
the 9 band stacked images will provide information about the differences in NDVI values over the season 
(90th and 10th percentile NDVI value over the growing season). Using information about NDVI has been 
reported to better map subtle changes in agricultural lands – depending on the type of crops being 
grown (GIZ 2013). The instructions are for the 6 band – just the stack with the Landsat bands, but you 
can simply change the input files to the 9 band and run with the ndvi information.   

1. First you need to stack the two images together. To create a layer stack of your images, click 
Raster > Miscellaneous > Merge. This will open the Merge dialog.  

i. Click Select to the right of Input files. Select the two subset cloud free Landsat composite 
images: 2008_Sub_6band.tif and 2013_Sub_6band.tif, both in 
C:/Change_detection/Data/Composite/imagery_subset.  

ii. Click Select to the right of Output files and navigate to 
C:/Change_detection/Data/Composite/imagery_subset/. Provide an appropriate file name, 
like Sub_08_13_6band.tif for example. 

iii. Check the box next to Place each input file into a separate band. 

iv. In the Merge dialog, leave all other options as is. 

v. Select OK.  

2. This will add the stacked image to the QGIS canvas. 

i. If it’s still open, Close the Merge dialog box. 

Note: This is also possible via the QGIS command line shell using gdal_merge.py. When doing this, the ‘-
separate’ option must be specified to create a layer stack (see http://www.gdal.org/gdal_merge.html 
for documentation). 
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3. Return to the Processing Toolbox to open the PCA tool. Go to Orfeo Toolbox > Image Filtering > 
DimensionalityReduction (pca). 

 

i. For the Input Image select your multi-date image stack 
(C:/Change_detection/Data/Composite/imagery_subset/Sub_08_13_6band.tif).  

ii. The number of components depends on the number of input features, but for the multi-
temporal stack of 12 bands, 6-8 components are recommended.  

iii. Uncheck the box that says Normalize. This function normalizes the variance of the different 
variables. This is useful if your variables are in different units (meters and grams).  

iv. For Output Image select to save to file. Give it an appropriate name (e.g., PCA_08_13.tif) and 
save to C:\Change_detection\Data\Composite\imagery_subset.  

v. Click Run.  

vi. Click Close to close the dialog box. 

4. Both the Output Image and the Inverse Output Image load. Turn off or remove the Inverse Output 
Image. 

Note: The layer is automatically loaded into the QGIS project with a Multiband color display image for 
Band 1, 2, 3. Both the Output Image and the Inverse Output Image load. 
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The resulting image has several principal components (6-8 in this case). The first layer represents the 
value for each pixel along the first principal component axis of variability. Often, this represents the 
overall variation in reflectance in the image. The next few components (next few bands) might be where 
the change is noticeable. 

5. Zoom into the sample areas of change (from the Change_Examples.shp file). Then set the display 
of each PC band individually to see if any of them capture the change. Start with Band 1. 

i. Right click the PCA stack in Layers panel > Properties > Style.  

ii. Set the Render type to Singleband pseudocolor.  

iii. Change to Band 1 (Gray).  

iv. Select Classify. 

v. Apply the changes. 

vi. Does anything stick out to you?  
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6. Repeat with Band 2.  

 

7. Repeat with the other bands. 
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8. Look at areas that you assume to be stable; do any patches present themselves in any of the PC 
layers? For example, look at the Khao Phanom Bencha National Park (in the middle of all the 
change example polygons).  

9. I found PCs 2 and 3 turned out to be useful for change detection.  

B. Multivariate Alteration Detection 
Another method for change detection between multiple images is called the Multivariate Alteration 

Detector. MAD is based on the theory of conical correlation analysis, which when used on remote 

sensing data seeks to transform the data through linear combinations that maximize correlation 

between the variables. Each image is transformed into new images with layers representing each 

canonical variate. The first variate represents the linear combination containing the most correlation in 

the image, and with subsequent layers containing decreasing correlations. The theory of MAD is that by 
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performing this linear transformation on both images, the difference between the two will accentuate 

areas of change in the image. 

1. In the Processing Toolbox go to Orfeo toolbox > Feature Extraction > Multivariate alteration 
detector. 

i. For Input Image 1 select either of your subset (6 or 9 band) images.  

ii. For Input Image 2 select the other (6 or 9 band) subset image.  

iii. For Change Map select an appropriate name, such as MAD_transform.tif. Save it to the 
following folder - C:\Change_detection\Data\Composite\imagery_subset.  

iv. Click Run. 

 

Once you have your output map, it too will load like the PCA output (a Multiband color display image 

for Band 1, 2, 3).  



Remote Sensing for Forest Cover Change Detection 21 

 

 

2. Try looking at the first few layers individually. Use what you learned in the previous steps to apply 
a single-band (pseudo color) stretch to band 1 of the output image – repeat for the other bands as 
well. 

Note: Areas of change should be visible in the first few bands. Does anything stick out? If there are any 
unusual areas where you thought it was stable, this could be areas of change. Below is an example of 
band 4 of the MAD image. 

 

 Data prep for change classification 

To classify change in your images, you are going to use a direct change classification approach. For this, 

you are classifying your images in a similar fashion to how you classified them in the previous exercise. 

However, now you are going to include change classes in the classification. 

A. Select and format your NBR multi-temporal transform 
1. Select the multi-temporal transforms that you think would be good change predictors. You will 

select the NBR_Diff layer; but you can select others if you like… 
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2. Next you need to prepare the raster to go from a float format to an integer format during the 
layer stack process. Open Raster Calculator (under Raster). 

3. Populate the Raster calculator expression box such that you are multiplying your NBR multi-
temporal transform layer by 1000. See an example below. Name it (NBR_Diff_1000.tif) and save it 
to the imagery_subset folder. 

4. Select OK. 

 

5. Next convert the output to an integer file. Open Raster > Conversion > Translate (Convert 
format). 

i. Select the NBR_Diff_1000.tif as the input layer. 

ii. Name the Output file NBR_Diff_1000_Int.tif. 

iii. Click on the pencil to edit. Then insert -ot Int16 in between the word GTiff and the path to 
the input file (see following image for an example). 
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B. Stack your images with your multi-temporal transform  
Now you need to stack the input images. Create an image stack with both subset images in addition to 

your NBR multi-temporal transform. If you did one of the optional transforms (PCA or MAD), try 

including that in the stack – after multiplying each band by 1000 and converting to a 16 bit integer.  

1. Use Raster > Miscellaneous > Merge. 

i. For the input files, include the two cloud free composite subsets (either the 6 or 9 band) and 
any difference layers (NBR_Diff or PCA or MAD output). For example:  
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(a) 2008_Sub_6band.tif  

(b) 2013_Sub_6band.tif  

(c) NBR_Diff_1000_Int.tif 

ii. For the Output file, save it as d1d2_NBR_stack_sub.tif to 
C:\Change_detection\Data\Composite\imagery_subset. 

iii. Check the box next to the option: Place each input file into a separate band. 

iv. Select OK. 

v. Close the dialog box. 

Note: the output will have 13 bands. If you followed the order from the instructions above, the first six 
are the six bands from the 2008_Sub_6band.tif, bands 7-12 represent the six bands from the 
2013_Sub_6band.tif, and the final band is the NBR difference value (NBR_Diff_1000_Int.tif).  

C. Adjust the display 
1. Set the No data value as -32768 (under Transparency in the Layer Properties).  

2. Use what you’ve learned during the online training course to change the image display to 
something you like – something that will be useful while you generate your ROI’s. For example, 
you could set the Band 13 (the NBR difference layer) to a Singleband pseudocolor.   

Note: This is where keeping track of what each band represents gets tricky. The bands are stacked in the 
order that they were ingested in the merge command. It’s helpful to keep a table that you can refer back 
to; include the band number, its alias, and parent data set in your notes table each time you run a merge 
to create a new data set.  

D. Define your ROIs for change classification 
Use your input stack, and other data layers you’ve generated in this exercise, to locate areas of change 

in your image. Create ROIs for these new map classes and your old classes as well. When you are done, 

you should have ROIs for both the stable and the change classes.  

The change classes you choose are based upon what you are trying to study. If you are looking for 

deforestation, find examples of such areas and collect ROIs and label them as “deforestation”. If you 

want to study urbanization, include that as a change class.  

1. Fill in your stable and change classes in the table below (suggestions have been included in grey, 
but feel free to change/edit). 

Land Cover Class Numeric Value 

Forest (stable) 1 

Water (stable) 2 

Other (stable) 3 

Forest Loss 4 

Forest Gain 5 

  

  

2. Use what you learned in the Exercise 7 to help guide you in creating appropriate ROIs (for 
instructions, refer to Ex 7, Part 3). 
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Hint: You can use the Change Examples polygons to help you track down areas undergoing changes to 
forestlands over time. 

3. Assess the spectral signatures of your ROIs. Again, revisit Ex 7, Part 3 if you need to review the 
ROI tool. 

4. Name your new ROI shapefile ROI_2.shp. 

Note: If you’ve specified the forest loss and gain well, you should expect to see the loss (red band below) 
at the lower end of the NBR difference layer (Band 13 in the stack), while gain (purple band) is at the 
upper end. What other differences do you see? What do you notice about the measures of variation 
(error bars)?  

  

 Classify your change map 

Now that you have collected your ROIs, you can classify your change map. Use the same methodology 

that you performed in the previous exercise.  

A. Train the classifier 
1. Make sure that the image you intend to classify and the vector file containing the ROIs are in the 

Layers panel. 

2. Go to Processing > Toolbox. In the toolbox that pops up on the right side of the screen double 
click Orfeo Toolbox > Learning > TrainImagesClassifier(rf). 
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Note: If the Orfeo Toolbox isn’t an option in the Processing Toolbox, you’ll need to use the drop down 
menu at the bottom of the Processing Toolbox to select the Advanced interface. 

i. For the Input Image List, select your date 1/date2 stacked/multi-temporal transform image, 
e.g., d1d2_NBR_stack_sub.tif.  

ii. For Input Vector Data List select your ROI shapefile, e.g., ROI_2.shp.  

iii. Make sure the Name of the discrimination field is the name of the integer attribute you used 
to differentiate the classes (id).  

iv. For Output Model, click Save to file… and save it as a run_CD.txt file in 
C:\Change_detection\Data\Models. 

v. For now, leave the other fields as they are.  These are different parameters for what goes into 
the Random forests classification. If you’d like, you can play around with the different 
parameters and see how they affect the end results.  When doing so, you will need to retrain 
the classifier with new output models.   

vi. To train the classifier click Run. 

vii. Close the dialog after it has processed. 

B. Apply the random forests model to classify the two date image stack 
You should now have a text (.txt) file saved that contains all the information needed to classify your 

image. Now the Random forests classifier can use the information in this model and apply it to the rest 

of the pixels in the image. 

1. To find the tool needed for classification, return to the Processing Toolbox and go to Learning > 
Image Classification. 

i. For Input Image select your two date image stack (d1d2_NBR_stack_sub.tif);  

ii. For Model file select the text file you created in the step above 
(C:\Change_detection\Data\Models\run_CD.txt); and 

iii. For Output Image select Save to file… Save it with a descriptive name, such as 
LC_08_13_NBR.tif, in the C:\Change_detection\Data\Composite\imagery_subset folder.  

iv. Leave the rest of the fields as they are.  

v. Select Run. 

2. Close the dialog after it has processed. 

3. Adjust the display to see the output classes. Right click the map in the Layers panel > Properties > 
Style to change the name and color of the classes.  

i. Render type: singleband pseudocolor 

ii. Classes: the number of land cover categories you included in your classification scheme - five 
if you used the following categories: forest, water, other, forest gain, and forest loss. 

iii. Select Classify. 

iv. Now in the box with the values, color swatches and labels you can double click on any of 
these to edit them.  

(a) Edit the labels to be text values – e.g., change ‘1’ to ‘forest’, etc. Hint: use your table 
from Part 5 D of this exercise to update. 
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(b) Double click on each color swatch to change it to a color that matches land cover 
expectations (e.g., water is usually set to a blue display, etc). 

(c) Select OK to apply the updated settings to view your classification. 

 Evaluate and Refine Map 

A. Inspect the results.  
1. What do your change areas look like? Did you capture the changes you expected?  

2. Are the areas you expected to be stable, stable in the output?  

 

3. Are the areas marked as forest gain always a gain in forestlands? Or is a label such as re-greening 
or forest growth more appropriate? How about forest losses vs forest degradation? Hint: refer to 
the charts below to see how a measure of greenness, NDVI, values change over time with two 
different change agents. 
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4. You can revise the map using what you learned in Exercise 7 – such as modifying ROIs and input 
data, using sieve, implementing object-based classification, or clean-up of the map. Redo just as 
you did when creating the single date land cover map until you are happy with the results. 

Note: if you decide to use object based classification methods (meanshift segmentation), it’s important 
to understand what kind of land cover transitions you will ‘filter out’ and mark as stable. A change agent 
that operates at a large spatial scale – such as plantations – will most likely be captured using the 
segmentation methods. What do you think about capturing small scale changes, such as growth of 
settlements, when segmenting the landscape? 

Note about scales of change and minimum mapping units:  

It is important that the varying scales of change occurring on the landscape are taken into account. 
Different land cover types (and subsequent change of these types) are characterized by different 
minimum mapping units (i.e., the size of the objects required to capture the feature or phenomenon). 
While image resolution will always be a limitation you may still need to map features / phenomena 
within your projects at different scales. For example, in this online training course you are working with 
Landsat imagery and cannot capture features / phenomena smaller than 30 m. When you create 
segments, it is not possible to capture features / phenomena smaller than those segments.  
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The objects of interest may vary in size depending on what you are trying to capture. For example, new 
development of built-up lands will likely occur at a very fine scale, while transition from natural forest to 
cleared land may occur at a much larger spatial scale. The goal is to preserve as many scales of features 
/ change phenomena as possible. 

Congratulations! You have successfully completed this exercise.  
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Exercise 10: Accuracy Assessment 

Introduction 

In this Exercise you will select a sample of reference observations of the study area with the aim of 

estimating the area of forest change. You will also use the sample for estimating accuracy of the map 

and map classes. If stratifying, any map can be used as stratification but the instructions will refer to the 

land cover change map that was constructed in the fourth Module, Change Detection. The basic idea 

here is the assumption that the mapped areas of land cover (or change in land cover) are biased because 

of image classification errors. These errors are identified by comparing the map to a sample of reference 

observations. Area estimates and accuracy are then inferred by analyzing the sample. This process 

includes three main steps: 1) design and selection of sample; 2) response design: interpretation of 

sample and decision of agreement of reference and map observations; and 3) analysis of sample.  

Objectives 

 Learn about the design and selection of a sample. 

 Learn about response designs and practice generating reference data from a combination of 
remotely sensed data sources including the cloud free composite and an archive of high 
resolution aerial imagery available in Google Earth. 

 Estimate the change area and accuracy of the change map. 

 Project Set up 

A. Open a QGIS project 
1. Start QGIS by clicking on the QGIS shortcut on your desktop   

B. Load the change classification raster and two date cloud free 
composite data sets 
1. Click on the Add Raster Layer icon.  

2. Navigate to the C:\Change_detection\Data\Composite\imagery_subset folder. 

3. Select the LC_08_13_NBR.tif, 2008_Sub_9band.tif, and 2008_Sub_9band.tif rasters. You can hold 
down the Ctrl key while selecting the rasters with your mouse to select them all. 

C. Adjust display settings 
1. Right click the LC_08_13_NBR.tif layer in the Layers panel > Properties > Style to change the 

name and color of the classes. Refer to previous exercises for instructions on how to do this.  

2. Adjust the display of the 2008_Sub_9band.tif and the 2013_Sub_9band.tif images. 

3. Save your project as Area_estimate.qgs. 
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 Sample Design 

The sampling design is the protocol for selecting the subset of spatial units (e.g., pixels or segments) that 

will form the basis of the analysis of area and accuracy. It is recommended that the sampling design is a 

probability sampling design, which incorporates randomization in the selection protocol and is defined 

in terms of inclusion probabilities such that the inclusion probability is known and greater than zero for 

each unit in the sample. A variety of probability sampling designs are applicable, with the most 

commonly used designs being simple random, stratified random, systematic and clustered. When 

choosing a design, three main decisions are: (1) whether to use clusters; (2) whether to use strata; and 

(3) whether to use a systematic or simple random protocol. 

The primary motivation for cluster sampling is to reduce the cost of data collection – for example, if the 

map is large and high resolution data need to be collected for each unit in the sample, a clustered design 

will allow for collection only for the primary sampling units and not for the entire population (cluster 

designs as defined in this text include 2-stage designs). However, the use of clusters is recommended 

only if cost savings or practical advantages are substantial as it results in a more complex analysis and 

because the potential correlation among units within a cluster (i.e., intracluster correlation) often 

reduces precision relative to a simple random sample of equal size. The use of strata is usually 

motivated by the fact that land cover change is a small proportion of the total map and if not stratifying 

the sample, a very large sample might be required to implement the analysis. A stratified design is 

therefore usually a good choice, especially if the aim is to estimate land cover change.  

The change map that was created in Exercise 9 contained a certain number of classes (including forest 

cover loss and gain) but the theory and methodology is generic and could be applied to any thematic 

map regardless of how the map was made and regardless of the nature and number of map categories. 

As the aim is to estimate the area of forest change, it is recommended to use the map classes as strata. 

This will ensure that a sufficient sample size for estimation can be allocated to the change classes.  

After settling on a sampling design – stratified random in this case – you will need to determine the total 

sample size and allocation of the sample to strata.  

A. Update the area, measured in pixels, of each land cover class in the 
classified map 
1. Determine the areas of each map category using a gdal tool called from the OSGeo4W Shell. 

Return to the Shell and type in the following: 

gdalinfo -hist C:\Change_detection\Data\Composite\imagery_subset\LC_08_13_NBR.tif  

Note: The return looks a little messy. The information you are interested in is the summary below the 
bucket information line (highlighted in red in the image below). It gives you the count of the number of 
pixels in each ‘histogram bucket’. In this example, the histogram is broken up into 5 buckets – starting at 
0.6 to 5.4.  

This indicates that there are: 

- 5,539 pixels with a value between 0.6 to 1.5 (water land cover);  
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- 54,484 pixels with a raster value between 1.6 and 2.5 (forest land cover);  

- 13,932 pixels with a value between 2.6 and 3.5 (other land cover);  

- 7,685 pixels with a value between 3.6 and 4.5 (forest loss land cover); and 

- 27,140 pixels with a value between 4.6 and 5.4 (forest gain land cover)  

See image on following page… 

 

 

2. In the table below, fill in the number of pixels of each map class. In the Exercise 9 example, 
gdalinfo gives the following areas in pixels.  

3. Calculate the Total number of pixels by adding together the pixel counts of all land cover 
categories. Fill this into the final column, Total. 
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4. Calculate the percent coverage (Wi) by dividing the strata total by the sum of all strata. Fill these 
values into the third row of the table.  

 

Example Table: 

 Water Forest Other Forest loss Forest gain Total 

Area 5,539 54,484 13,932 7,685 27,140 =108,780 

Wi 
5,539/108,780= 
5.1% 

54,484/108,780= 

50.1% 
13,932/108,780= 
12.8% 

7,685/108,780= 

7.1% 
27,140/108,780= 

24.9% 
 

 

Your Table: 

 Water Forest Other Forest loss Forest gain Total 

Area       

Wi      
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How to Determine Your Sample Size: 

To determine the sample size for a stratified random sample, you can use Eq. 5.25 in Cochran (1977): 

𝑛 ≈ (
∑ 𝑊𝑖𝑆𝑖

𝑆(𝑃̂)
)

2
 

𝑊𝑖 is the stratum weight and  

𝑆𝑖 is the standard error for stratum i; estimated as √𝑝𝑖(1 − 𝑝𝑖),  

𝑝𝑖  is the proportion of forest loss in stratum i.  

𝑆(𝑃̂) is the target standard error of the forest loss estimate.  

If you assume one error of omission of forest loss in non-forest and forest per 100 units and a user’s 

accuracy of 0.8 and a target standard error, 𝑆(𝑃̂), of the forest loss estimate of 0.5% (i.e., a confidence 

interval of 1%); you get the following information for determining the sample size: 

 Water Forest Other Forest loss Forest gain  

Area 5,539 54,484 13,932 7,685 27,140  

Wi 
5,539/108,780= 

5.1% 
54,484/108,780= 

50.1% 
13,932/108,780= 

12.8% 
7,685/108,780= 

7.1% 
27,140/108,780= 

24.9% 
 

pi 0 

1 error of 
omission/100= 

0.01 

1 error of 
omission/100= 

0.01 

User’s accuracy= 
0.8 

 
1 error of omission/100= 

0.01  

Si 0 

√. 01(1 − .01)
= 

0.099 

√. 01(1 − .01)
= 

0.099 

√. 8(1 − .8)= 

0.4 

√. 01(1 − .01)= 

0.099 
 

S(𝑷̂)   0.005    

Now plug the numbers from the table into the equation to solve for n: 

𝑛 ≈ (
0.051 ∗ 0 + 0.501 ∗ 0.099 + 0.128 ∗ 0.099 + 0.071 ∗ .4 + 0.249 ∗ 0.099

0.005
)

2

 

𝑛 ≈ (
0.115

0.005
)

2

 

𝑛 ≈ (23)2 

𝑛 ≈ 532 

Note: this is just an example and users need to specify their own target errors and expected accuracy 

and omission errors. 
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The second step is to determine how to allocate these units to strata. Good practices stipulate that 

these are allocated proportionately based on area, with at least 50, 75, or 100 units are allocated to the 

all classes. In this water and forest loss have fewer than 50 samples, so increase these to 50, resulting in 

final sample size of 567. 

   

 Water Forest Other Forest loss Forest gain 

𝒑𝒓𝒐𝒑𝒐𝒓𝒕𝒊𝒐𝒏𝒂𝒍 𝒏𝒊  
532 * 0.051= 

27 
532 * 0.501= 

267 
532 * 0.128= 

68 
532 * 0.071= 

38 
532 * 0.249= 

132 

𝒇𝒊𝒏𝒂𝒍 𝒏𝒊  

Since 27< 50, 
increase 

sample size:  
50 

 

267 

 

 

68 

 

Since 38< 50, 
increase 

sample size: 
50 

 

132 

 

 

 

B. Select Sample 
For this exercise, you are going to keep things simple. Use 10 sample reference plots per land cover class 

strata. Now you will select the sample.  

1. Open the OSGeo4W command line shell. Go to your desktop and double-click the OSGeo4W.bat – 
Shortcut.  

2. Once the shell opens, navigate to the directory where the land cover classification output is 
stored. 

cd C:\Change_detection\Data\Composite\imagery_subset 

3. Revisit the sample script input options: type the command below. This will open a dialog with 
descriptions about the different options.  

python C:\QGIS_Scripts\sample_map.py -h  
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4. To select a stratified random sample, type:  

python C:\QGIS_Scripts\sample_map.py -v --mask 0 --size 50 --allocation "10 10 10 10 10" --vector 

change_sample.shp stratified LC_08_13_NBR.tif 
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Note: when it’s done running, you will see a screen like this which indicates the sampling has completed. 
This has now created a shapefile called change_sample.shp that contains the stratified random sample 
with 10 points per strata based on the LC_08_13_NBR.tif raster you generated in Exercise 9. 

 

 

C. Load the sample into the QGIS project 
1. In QGIS, click the Add Vector Layer icon. Browse to the working directory 

(C:\Change_detection\Data\Composite\imagery_subset) and select the shapefile you just 
created, called change_sample.shp. 

  



Remote Sensing for Forest Cover Change Detection 38 

 

 Response Design 

Once you chose your sample design (e.g., random, uniform) and created a shapefile of your sample 

plots, the plots need to be interpreted using a suitable source of reference data. Then you will need to 

decide if the map and reference observations agree. This step is referred to as the response design.  

First, you will need to identify the reference data sources. Ideally you would have plots revisited in the 

field, but if this is not feasible you can collect reference observations through careful examination of the 

plots using satellite data. The more data you have at your disposal, the better. If you have no additional 

data you can use the Landsat data for collecting reference observations – as long as the classification 

process is more accurate than the process used to create the map being evaluated. Typically, careful 

manual examination can be regarded as being a more accurate process than automated classification. In 

addition to Landsat data, you can use whatever data are available in Google Earth™. As the estimates 

are based on the sample, it is important that the labels are correct and it is recommended that three 

interpreters examine each unit independently. 

A. Loading reference data (e.g., Landsat and aerial imagery) 
1. You have already displayed the reference data (i.e., the data you will use to interpret the sample 

you just created) in QGIS. This data set is the cloud free composite data you’ve been working with 
throughout the online training course.  

2. Load any additional data that is available, such as RapidEye, acquired around the same times as 
the data used to create the map (in this case 2008 and 2013). 

3. You can also load the sample points into Google Earth™ to access their online imagery library. 

i. Right click on change_sample in the layers panel. Select Save As. 

ii. Use the drop down menu to change the Format to Keyhole Markup Language [KML]. 

iii. Click Browse and save the file as change_sample in the imagery_subset folder.  

iv. Uncheck Add saved file to map. 

v. Change the Symbology export to Feature symbology. 

vi. Select OK. 

4. In Windows Explorer, navigate to the imagery_subset folder and double click on the newly 
created kml file, change_sample.kml. This will open the data set of plot locations in Google 
Earth™.  

i. In the Places panel on the left hand side of the screen, you can expand the list of samples by 
clicking on arrows next to Temporary Places > change_sample.kml > change_sample. 

ii. Double click on any of the sample features in the list to zoom into that plot location. 

iii. Since you are interested in land cover and changes in land cover with this classification 
scheme - make sure you look at the data from the 2008-2010 time range and then the data 
from the 2013 -2015 time range when you are determining the class of each reference plot. 
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B. Interpreting sample 
1. Return to QGIS and right-click the change_sample shapefile in the Layer pane. Select Open 

Attribute Table.  

i. Then select the Toggle Editing Mode (the pencil icon): 

 

ii. Then the Delete Column icon (table with a red box with an ‘x’). 

 

iii. Highlight and delete the STRATUM column. 

2. Click the New column button to add a column;  

 

i. Name it “Reference”;  

ii. Change width to 3; 

iii. Leave the other options as the default.  

3. Now provide a label for each of the units in the sample by manually examining the reference data. 
Add labels that correspond to the grid codes of the map: for example, if the forest class has the 
grid code “2” in the map, then provide each sample unit exhibiting forest with the label “2”.  

i. Refer to the cloud free composite values and the aerial imagery (from around 2008-2010) in 
Google Earth™ to determine what the land cover is at each plot location.  

ii. You can click Zoom map to selected row button in the attribute table to jump to the 
highlighted plot.  

 

iii. Make sure you save the edits to your shapefile regularly. 

 

4. Click the Toggle Editing Mode button again to complete your editing session. 

5. Since your final area estimates are based on the interpretation of this sample it is important that 
the labels are correct – if you can’t provide a correct label then delete the unit rather than 
guessing.  

C. Construct the error matrix 
Once the sample has been interpreted, the agreement between map and reference labels needs to 

decided; this could potentially be a complicated task but in this case you are using the map classes as 

strata, which makes the decision straightforward. The agreement is preferably expressed in the form of 

an error matrix, which is a simple cross-tabulation of the map labels against the reference labels for the 
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sample units. The error matrix organizes the acquired sample data in a way that summarizes key results 

and aids the quantification of accuracy and area. The main diagonal of the error matrix highlights correct 

classifications while the off-diagonal elements show omission and commission errors. The cell entries 

and marginal values of the error matrix are fundamental to both accuracy assessment and area 

estimation. 

1. With each unit having a map label and a reference label you can construct an error matrix. This 
can be done in various ways but we recommend using a home-made script that executes in the 
terminal.  

2. Return to the OSGeo4W Shell and if it’s not still pointing to the working directory, navigate to 
where the sample shapefile and land cover raster (LC_08_13_NBR.tif) are located 
(C:\Change_detection\Data\Composite\imagery_subset). 

3. In the Shell, type python, the full pathname to the crosstab python script, -v, -a, the name of the 
column in the sample shapefile with the reference data, the name of the classified raster, the 
name of the sample shapefile, and finally the name of the file that you will be generating. See the 
example below. 

python C:\QGIS_Scripts\crosstab.py -v -a Reference LC_08_13_NBR.tif 

change_sample.shp Ch_errormatrix.txt 

i. This will create text file that contains the error matrix called Ch_errormatrix.txt in the 
imagery_subset folder. 

Note: If the script gives you an error regarding varying input shapes, check to make sure your raster file 
has the same number of classes as the shapefile. If the edges of your map contain 0s, you do not have 
any 0 values in your shapefile, and 0 is not the no data value of your raster, the script will not work.  

To fix this create a new raster with 0 as the no data value by going to Raster -> Conversion -> Translate. 
For Input Layer select the classified raster, select a name for the Output file, and for No data put 0 (or 
whatever you want to declare the no data value). 

 Analysis 

With the construction of an error matrix the estimation becomes straightforward. At the heart of the 

analysis is the implementation of an unbiased area estimator. Different estimators can be implemented 

but with a sample stratified by discrete map classes, stratified estimation has proven useful. A stratified 

estimator of area includes the area of omission but excludes the error of commission, and is easily 

implemented from the data in the error matrix. Using the error matrix one can also estimate the 

accuracy of the map and the map classes.  

Note that stratified estimation can be used with simple or systematic random samples too.  

The error matrix (with the mapped areas of each map category) contains all the information needed to 

perform the analysis which includes stratified estimation of area and confidence intervals. Again, this 

can be done various ways, but we recommend implementation in a spreadsheet program to provide the 

user with an understanding of the estimation procedure.  
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A. Open the error matrix in a spreadsheet software 
1. Open Microsoft Excel. 

2. In Excel, go to File > Open > browse.  

i. Change the type from All Excel Files (*.xlsx…) to All Files (*.*).  

ii. Open the text file created in previous steps.  

iii. Choose Delimited. Click Next. 

iv. Select Comma as the Delimiter. Click Next. 

v. Then Finish. 

vi. The screen should like below: 

 

3. Rename the columns and rows so that they are more intuitive to work with. In this example. Class 
1 is water, class 2 is forest, class 3 is other, class 4 is forest loss, and class 5 is forest gain. Rename 
the table headers accordingly. See example below. 

4. Save the file as an Excel Spreadsheet 

i. Click File > Save As 

ii. Change type From Text (Tab delimited) (*.txt) to Excel Workbook (*.xlsx) 

iii. Click Save 

 

B. Below the error matrix output, invert the matrix 
1. Below the sample error matrix information – duplicate the matrix, but invert the information 

(such that the reference information is stored as columns, and the map information is stored as 
rows). 

i. Starting with cell A6, click and drag your mouse down to cell D9. 
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ii. In the function bar, type in =transpose(A1:D4) and hold down the Ctrl + Shift + Enter keys. 

iii. You will see that cells A6:D9 are now populated with the information from your error matrix, 
but the rows and columns have been transposed. 

 

2. Add the following labels to the columns on the right hand side of the just copied table header:  

i. Map Total 

ii. Pixels 

iii. W_i 

3. Add Reference Total as a row header at the bottom of the map labels. 

4. You can also format the cell borders and fill to make it easier to read. I’ve highlighted the 
agreement cells on the diagonal in orange. 

 

C. Calculate reference and map sums 
1. In the cell to the right of the Reference Total cell, total the number of instances where the forest 

category appears in the reference data by entering the following: 

=sum(B8:B14) 
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2. Repeat for the other reference land cover classes. 

 

3. Repeat the summing process for the Map Total counts. 

 

D. Update the area, measured in pixels, of each land cover class in the 
classified map 
1. Revisit the table with the area covered by each stratum from Part 2 of this Exercise. I’ve re-copied 

the example table below.  

Example Table: 

 Water Forest Other Forest loss Forest gain Total 

Area 5,539 54,484 13,932 7,685 27,140 =108,780 

Wi 
5,539/108,780= 
5.1% 

54,484/108,780= 

50.1% 
13,932/108,780= 
12.8% 

7,685/108,780= 

7.1% 
27,140/108,780= 

24.9% 
 

2. Use this table to fill in the Pixels (count of pixels per stratum) and W_i columns in the 
spreadsheet.  

i. You can calculate the weights using the formula in the upper part of the image below as a 
template – or just write them in directly.  

(a) Type the equal sign, move the cursor over to the pixel count cell on the same row, then 
type in sum(, highlight the three pixel count cells, then close the parenthesis.  

(b) The dollar signs in the formula keep the cell constant as you copy and paste the formula 
into other cells. 
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E. Estimating area proportions 
In this case, the sample is stratified and the number of sample units per stratum is disproportionate 

relative to the area of the stratum; it is therefore necessary to estimate the area proportions (𝑝̂𝑖𝑗) for 

each cell in the error matrix rather than sample counts before proceeding with the analysis.  

The area proportions are estimated as: 

𝑝̂𝑖𝑗 = 𝑊𝑖 × 𝑛𝑖𝑗 ÷ 𝑛𝑖  

Where:  

 𝑊𝑖 are the stratum weights (the area proportion of stratum i),  

 𝑛𝑖𝑗 is the sample count in cell i,j, and 

 𝑛𝑖 is the total number of sample counts in map category i.  

1. Type Error matrix, estimates area proportions below the Inverted Error Matrix. 

2. Copy the inverted matrix and paste below the Error matrix, estimates area proportions title.  

3. Delete the numbers inside the error matrix that you’ve just copied. See image below. 
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4. In the first data cell in the Error matrix, estimates area proportions matrix, calculate 𝑝̂11 = 𝑊1 ×
𝑛11 ÷ 𝑛1 (the spreadsheet expression should be similar to “=$I10*B10/$G10” without the 
quotation marks; see screenshot below). 
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5. Then just populate the rest of the first row of the matrix by highlighting the first cell and then 
“grabbing” the little black square at the bottom right of the cell (mouse pointer turns into a plus 
sign) and drag to the end of the row.  

6. Then highlight the first row of the matrix and drag down to populate the entire matrix. 

 

7. Highlight all cells > right click > Format cells... >   

i. In the Number tab, set Category to Number with 4 decimals.   

ii. Select OK. 
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F. Calculate Area Estimates 
1. The error matrix you just created contains all of the information required for stratified estimation 

area! And estimators are now easily obtained as the column totals of the estimated area 
proportions.  

2. Calculate the row and columns totals by typing =sum(, then highlight the row or the column, then 
close the parentheses.  

i. To check if you got it right: the row totals should equal Wi and the totals should sum to 1: 

 

3. You have just calculated unbiased estimates of area! These are the column totals.  

Note: To express these in hectares, rather than proportions, multiply the column totals (cells B25 to F25) 
by the map size and the pixel size in hectares (302/1002). For example, an unbiased area estimate of the 
water class in hectares is calculated as “=B25*SUM($H$20:$H$24)*30^2/100^2”.  

4. Run the hectare conversion in two steps.  

i. First calculate the area, as a count of pixels, for all classes. Populate the cells on row 26 with 
the pixel count. E.g., in cell B26, type in “=B25*SUM($H$20:$H$24)”. Copy and paste this 
equation into the rest of the cells in the row. 
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(a) Note, you can then calculate the sum to make sure it matches the total map area. E.g., in 
cell G26, run the equation “=SUM(B26:F26)”. Does the result match the sum in cell H25? 
It should. 

ii. Now convert the pixel count to area, expressed in hectares by multiplying the count by 900 
(30m by 30 m, aka 302, is the size of the Landsat pixel). Then divide by 1,000 (1002 is the 
conversion factor to convert square meters to hectares). In cell B27, type 
“=B26*30^2/100^2”.  

(a) Copy and paste this expression into the other cells in row 27 – make sure that the 
reference to the count cell reflects the appropriate land use. E.g., cell C27 should have 
the following expression “=B27*30^2/100^2”. 

 

G. Calculate Standard Errors of Area Estimates 
The next step is to calculate the standard errors of the area estimates, which are given by the following 

equation for a stratified random sample:     

S(𝑝̂∙𝑗) =  √∑
𝑊𝑖𝑝̂𝑖𝑗 − 𝑝̂𝑖𝑗

2

𝑛𝑖∙ − 1
𝑖

 



Remote Sensing for Forest Cover Change Detection 50 

 

1. This can be tricky to get right in a spreadsheet! Calculate the standard errors in row 28.  

i. The standard error - S(𝑝̂∙1) - for the water map (class 1, the first column total) is calculated as:  

=SQRT(($I$20*B20-B20^2)/($G$10-1)+($I$21*B21-B21^2)/($G$11-1)+($I$22*B22-B22^2)/($G$12-

1)+($I$23*B23-B23^2)/($G$13-1)+($I$24*B24-B24^2)/($G$14-1)) 

 

ii. Then just click the plus sign at the lower right hand side of the cell and drag it across the row 
to complete the calculations for the other classes. 

2. Now, calculate the standard errors in the units of pixels by multiplying by the total number of 
pixels (in the example it’s 108,780).  

 

3. Then calculate the standard errors in the units of hectares by multiplying pixel standard error 
measure times the pixel to hectare conversion unit. The conversion unit in this example is 
30^2/100^2.  
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4. 95% confidence intervals are given by multiplying the standard errors by 1.96.  

 

H. Estimating map accuracy 
Finally, you can estimate the accuracy of the map. Three different accuracy measures are of interest:  

 overall accuracy which is simply the sum of the diagonals in the error matrix of estimated area 

proportions;  

 user’s accuracy which for a map category i is given by 𝑈̂𝑖 = 𝑝̂𝑖𝑖 ÷ 𝑝̂𝑖∙  

 producer’s accuracy for map category j given by 𝑃̂𝑖 = 𝑝̂𝑗𝑗 ÷ 𝑝̂∙𝑗 where  𝑝̂𝑖∙ and 𝑝̂∙𝑗  are the row 

and columns totals respectively.  
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1. In the example below, I calculated:  

i. user’s accuracy in row 34 (𝑈̂1=B20/G20),  

ii. producer’s accuracy in row 36 (𝑃̂1 =B20/B25), and  

iii. overall accuracy in row 37 (=sum(B20,C21,D22,E23,F24)).  

This gives the final spreadsheet with area estimates in green cells and accuracies in blue cells: 

 

Congratulations! You have successfully completed this exercise.  


